EE2: AOS Bug - HERCs Force Shields look bad

ImageImageTalking about Modding for EE2 and EE2 AOS. New maps, patches, programs and Multiplayer scenarios.
Post Reply
User avatar
Dr.MonaLisa
High Representative
Posts: 7646
Joined: 17 Jun 2010, 11:21
Location: Poland

EE2: AOS Bug - HERCs Force Shields look bad

Post by Dr.MonaLisa »

Hi.

I noticed that the Force Shields of HERC Hades "Anti-Missile System" and HERC Hera "Cast Shield" are broken on EE2: AOS.

Here are examples:

Normal EE2 (looks good):
EE2_ScreenShot994.jpg
EE2_ScreenShot994.jpg (460.37 KiB) Viewed 67 times
EE2: AOS (looks bad):
EE2_ScreenShot586.jpg
EE2_ScreenShot586.jpg (367.08 KiB) Viewed 67 times
It is controlled by: EE2X_db.zip\EE2X_db\Visuals\effects_visual.ddf
The "HERC_AntiMissileSystem" and "HERC_Shield" doesn't differ in this file (it's the same on EE2, and the same on AOS).
I edited it to the following:

Code: Select all

//---------------------------------------------
//Force field
//
VisualForceFieldDC	HERC_AntiMissileSystem
{
	//Shield born
	fadeInSecond = 0.5
	fadeInScale = true
	fadeInTransparency = true
	//Shield death
	fadeOutSecond = 6
	fadeOutScale = true
	fadeOutTransparency = true
	//Geometry
	shieldNameVHigh = fx_anti_missile_aos15.nif
	shieldNameHigh = fx_anti_missile_aos15.nif
	shieldNameMedium = fx_anti_missile_aos15.nif
	shieldNameLow = fx_anti_missile_aos15.nif	
	impactNameVHigh = fx_anti_missile_splash_aos15.nif
	impactNameHigh = fx_anti_missile_splash_aos15.nif
	impactNameMedium = fx_anti_missile_splash_aos15.nif
	impactNameLow = fx_anti_missile_splash_aos15.nif
		
	// radius in world space
	// @NOTE - should match radius of shield
	//         in associated area effect.
	shieldRadius = 4
	
	//Message
	msgStartEffect = BeginForceField
	msgStopEffect = EndForceField
	msgImpact = HitForceField
}

VisualForceFieldDC	HERC_Shield
{
	//Shield born
	fadeInSecond = 0.5
	fadeInScale = true
	fadeInTransparency = true
	//Shield death
	fadeOutSecond = 6
	fadeOutScale = true
	fadeOutTransparency = true
	//Geometry
	shieldNameVHigh = fx_anti_missile.nif
	shieldNameHigh = fx_anti_missile.nif
	shieldNameMedium = fx_anti_missile.nif
	shieldNameLow = fx_anti_missile.nif
	impactNameVHigh = fx_anti_missile_splash.nif
	impactNameHigh = fx_anti_missile_splash.nif
	impactNameMedium = fx_anti_missile_splash.nif
	impactNameLow = fx_anti_missile_splash.nif
		
	// radius in world space
	shieldRadius = 2
	
	//Message
	msgStartEffect = BeginForceField
	msgStopEffect = EndForceField
	msgImpact = HitForceField
}
And I placed a copy of .nif files "fx_anti_missile_aos15.nif" and "fx_anti_missile_splash_aos15.nif" in zips\db_150.zip\graphics\cache\nifcache.
AOS seems to read the new file then. I tried to change some colors by editing .nif, but nothing helped to resolve this issue.
I believe it's rather a problem in .tga textures. I remember Loew used to fix tress for AOS in some way. It's possible that .tga textures need to be edited for AOS, to remove some incompatibility.

I tested and this bug is present on the normal EE2: AOS in ver. 1.0, so it's not related to any of UP1.5 updates.

Does anyone know what can be the problem, and can try to fix it?
Best regards,
Dr.MonaLisa
Ministry of Game Affairs
Department of Control and Complains


Post Reply

Return to “EE2 files, modding, maps, testing, etc.”