EE2, EE2X - Empire Earth II - Unofficial Patch 1.5 (2014+)

ImageImageTalking about Modding for EE2 and EE2 AOS. New maps, patches, programs and Multiplayer scenarios.
PaulStretch
Posts: 81
Joined: 27 Jun 2021, 16:10
Has thanked: 29 times
Been thanked: 7 times

Re: EE2, EE2X - Empire Earth II - Unofficial Patch 1.5 (2014+)

Post by PaulStretch »

All your work is greatly appreciated. This games wouldn't be what it is without you
These users thanked the author PaulStretch for the post:
Dr.MonaLisa

User avatar
Dr.MonaLisa
High Representative
Posts: 8367
Joined: 17 Jun 2010, 11:21
Location: Poland
Has thanked: 31 times
Been thanked: 56 times

Re: EE2, EE2X - Empire Earth II - Unofficial Patch 1.5 (2014+)

Post by Dr.MonaLisa »

Minor update 158023 has been released!

Update Type: Monthly Update. Changes: https://www.ee2.eu/patch/changes/#158023

- New BETA feature: "Advanced Cache Preloading", disabled by default, configurable by UP1.5 Settings:
* When enabled, Unofficial Patch 1.5 uses the new advanced methods to preload certain game files to the game cache on launch. It increases the time needed for the game process to start and causes much higher RAM usage, but reduces the number of mini-freezes that could occur e.g. when a sound, texture or model was loaded in the game for the first time. This feature uses the original game caching functions, so memory is not wasted and might be released by the game process when needed.
- Fixed compatibility with Gog version 54517:
* Fixed an issue where UP1.5 Launcher could continuously ask to change the screen resolution on Empire Earth II: The Art of Supremacy start. Thanks for the report to players: "sirphr" and "Hacker?pcs".
* The latest game files update from Gog could remove UP1.5 Launcher files. In this case, please re-install UP1.5 from the official download page: https://ee2.eu/patch
* Added an additional module which detects if the game / launcher files were overwritten. It shows an error with detailed information and helps to recover the UP1.5 installation.
- Updated calsch03's "Survival Egypt (survival game mode)" scenario on his request. Renamed the "Easy" mode name to "Short" and updated an AI player for slot 2.
- Updated some texts in Bogdan's "Cold War 1965" scenario on his request.

If you have got UP1.5.5+, you can update by clicking: empireearth2://FunctionMinorVersionInstall
Best regards,
Dr.MonaLisa
Ministry of Game Affairs
Department of Control and Complains
manan001
Posts: 2
Joined: 13 Apr 2022, 13:54

Re: EE2, EE2X - Empire Earth II - Unofficial Patch 1.5 (2014+)

Post by manan001 »

It would be great in next update if we have ore deadly missiles and range of modern weapons. War becomes much difficult and interesting. If anyone has any suggestion. Rest for Mod team if they can accept this request for addition of more deadly missiles.
User avatar
Dr.MonaLisa
High Representative
Posts: 8367
Joined: 17 Jun 2010, 11:21
Location: Poland
Has thanked: 31 times
Been thanked: 56 times

Re: EE2, EE2X - Empire Earth II - Unofficial Patch 1.5 (2014+)

Post by Dr.MonaLisa »

manan001 wrote: 24 May 2022, 13:45 It would be great in next update if we have ore deadly missiles and range of modern weapons. War becomes much difficult and interesting. If anyone has any suggestion. Rest for Mod team if they can accept this request for addition of more deadly missiles.
The similar answer has been provided there: viewtopic.php?f=54&t=1723&p=25862

Unofficial Patch 1.5 is a real patch, not just a mod. Therefore the modding requests like this one have a very low chance to be available in the patch.

The main problem is, that Unofficial Patch 1.5 has no alternative. Adding too much stuff to the game could negatively affect the gameplay, change the original balance or simply make some users dislike such changes. Stronger nuclear weapons could risk this strategy to be abused in Multiplayer games, which would result in total strategy / balance change compared to the vanilla game. Most of units / buildings that are currently available in UP1.5 have their costs higher than they should be. It's to prevent usage in the normal games, or not to give the chance of being used at the game start. There's a new nuclear weapon already available (Super ICBM) and it deals a lot of more damage / area than the original ICBMs. However, I can't imagine usage of even stronger weapons in this game. It would ruin fun for certain players, especially in the multiplayer mode.

I think it's best to keep 1.5 as minimal as possible (in the meaning of additional game units), and focus on the serious things like crash fixes, multiplayer improvements, etc. The ideas regarding extra stuff in game could still be posted on the forum. Maybe some other player decides to create a mod based on UP1.5 Developers Version, where such things would be available. Unfortunately, as I wrote, UP1.5 has too many users, too much trust from players over years, that we can't risk irresponsible changes to the game.
Best regards,
Dr.MonaLisa
Ministry of Game Affairs
Department of Control and Complains
Post Reply

Return to “EE2 Files, Modding, Maps, Scenarios, Scripting, Testing, etc.”