ImageNeed any help? Do you have a problem? Ask us! We will help you!
Post Reply
Traderhut Games
Posts: 2
Joined: 04 Nov 2017, 08:12


Post by Traderhut Games »


I've been playing EE1 and EE2 for a decade or so under Mac OS-X / Parallels running a Win-XP VM. It has been running about perfectly... Ok, well, some video issues on the startup, but I've seen it once and am fine just clicking through it. (sound is off)

I installed the patch, it threw an exception about not being able to find a method to Get Logical Processor Information (Kernel32.dll) (I assume it is a Post XP API Call to the OS), and clicked OK. I told it to run the config program and Windows Blue Screened and rebooted.

After a nice reboot, When I ran the program, it gives the same error And/or it blue screens. It seems to be just blue screening the OS since the last blue screen.

Is XP supported? I'd hate to go from a 6 GB VM to a 30 GB VM to run this app, but it does seem cool - we have always just been running the original game without any mods.

if you can help, that would be great!


User avatar
High Representative
Posts: 7646
Joined: 17 Jun 2010, 11:21
Location: Poland

Re: WinXP?

Post by Dr.MonaLisa »

Windows XP Service Pack 3 is supported by UP1.5 Launcher (video):
Could you please show the screenshot showing the error message?

Make sure your Windows XP has Service Pack 3 installed, because according to: ... 2147217396 the "GetLogicalProcessorInformation" function requires it.
I checked the Launcher source code and I doesn't make any calls to the "GetLogicalProcessorInformation" function (in my source), so it must be called by some other function which I am not able to detect nor modify.
You can download Service Pack 3 here: ... pack-3-sp3
Best regards,
Ministry of Game Affairs
Department of Control and Complains

Post Reply

Return to “Help, Questions & Problems. Empire Earth II Support.”