WW2 Panzers Mod

ImageImageTalking about Modding for EE2 and EE2 AOS. New maps, patches, programs and Multiplayer scenarios.
Post Reply
samcervantesc
Posts: 3
Joined: 08 Sep 2020, 20:08

WW2 Panzers Mod

Post by samcervantesc »

I know to play the patch with mods you have to install a much unpredictable creator's version.

I tried installing the old WW2 Panzers mods (that gives amazing new armored ww2-era units to Russia, Amerca, Britain, Italy, Japan, Germany and France). It used to be my favorite became the gameplay was absolutely epic with those units.

Has anyone installed it and succeeded? I've tried several times and get errors and effed the whole game and couldn't even play properly without the mod so I had to uninstall and install again.

Anyways, I'd appreciate a LOT if someone could help me with this :(

User avatar
Dr.MonaLisa
High Representative
Posts: 7836
Joined: 17 Jun 2010, 11:21
Location: Poland

Re: WW2 Panzers Mod

Post by Dr.MonaLisa »

You should be able to install this mod without problems, if you use Developers Version of UP1.5: https://www.ee2.eu/patch/developers/

You would need to:
1. Install a clean version of EE2 (+ AOS if required) to a new folder.
2. Paste UP1.5 Developers files to it (overwire existing files).
3. Paste other mod's files on it (overwire existing files).

This way you should be able to play it with screen resolutions, Windows 8 / 10 support and everything that is important in UP1.5.

Since other mods were editing files using the unchanged files structure, they only were compatible with 1 game language. In normal version of UP1.5 the files structure is heavily modified to not overwrite any original game files inside zips / zips_ee2x. It for a support for all available game languages.
Best regards,
Dr.MonaLisa
Ministry of Game Affairs
Department of Control and Complains
samcervantesc
Posts: 3
Joined: 08 Sep 2020, 20:08

Re: WW2 Panzers Mod

Post by samcervantesc »

Dr.MonaLisa wrote: 09 Sep 2020, 17:20 You should be able to install this mod without problems, if you use Developers Version of UP1.5: https://www.ee2.eu/patch/developers/

You would need to:
1. Install a clean version of EE2 (+ AOS if required) to a new folder.
2. Paste UP1.5 Developers files to it (overwire existing files).
3. Paste other mod's files on it (overwire existing files).

This way you should be able to play it with screen resolutions, Windows 8 / 10 support and everything that is important in UP1.5.

Since other mods were editing files using the unchanged files structure, they only were compatible with 1 game language. In normal version of UP1.5 the files structure is heavily modified to not overwrite any original game files inside zips / zips_ee2x. It for a support for all available game languages.
Thank you so much for answering, I certainly did not expect an answer from the creator! What you've created here is amazing!

However, I still can't get it right :( So, I tried everything but I get this

EXCEPTION: ACCESS VIOLATION
0x0082093f
0x00be4768
0x00b2c2e0
0x8b0474c9
EAX:0c1a991ch ESI:06c4405ch
EBX:00000000h EDI:00000004h
ECX:00000000h EBP:1489f81ch
EDX:ffffffffh ESP:0248fa8ch
EIP:0082093fh EID:00000000h
SS: 0000002bh CS: 00000023h
DS: 0000002bh FS: 00000053h
ES: 0000002bh GS: 0000002bh
Flags: 00010246h CF:0 PF:1 AF:0 ZF:1 SF:0 OF:0

(I followed every step, and the info page's steps)
User avatar
Dr.MonaLisa
High Representative
Posts: 7836
Joined: 17 Jun 2010, 11:21
Location: Poland

Re: WW2 Panzers Mod

Post by Dr.MonaLisa »

Are you sure you installed ee2 to a new folder? Not the one which already had ee2 + normal 1.5?
Best regards,
Dr.MonaLisa
Ministry of Game Affairs
Department of Control and Complains
samcervantesc
Posts: 3
Joined: 08 Sep 2020, 20:08

Re: WW2 Panzers Mod

Post by samcervantesc »

Dr.MonaLisa wrote: 10 Sep 2020, 09:46 Are you sure you installed ee2 to a new folder? Not the one which already had ee2 + normal 1.5?
Yes, I did everything :(

It's an old mod so it has probably a lot to do with that
User avatar
Dr.MonaLisa
High Representative
Posts: 7836
Joined: 17 Jun 2010, 11:21
Location: Poland

Re: WW2 Panzers Mod

Post by Dr.MonaLisa »

I'll try to get Loew to test this mod. Hopefully he's not too busy these days.
Best regards,
Dr.MonaLisa
Ministry of Game Affairs
Department of Control and Complains
User avatar
Loewenherz
Posts: 170
Joined: 23 Sep 2017, 17:26

Re: WW2 Panzers Mod

Post by Loewenherz »

Maybe is better to play the EE4 Mod? ;) He has includet the WW2 Panzer Mod.
List of tutorials, useful threads and utilities (look here before posting): Here

Add Pics to Map: viewtopic.php?f=54&p=25184#p25184

Loews Work: viewtopic.php?f=54&t=5160
User avatar
RGV1
Posts: 98
Joined: 13 Aug 2011, 11:22

Re: WW2 Panzers Mod

Post by RGV1 »

samcervantesc wrote: 08 Sep 2020, 20:14 I know to play the patch with mods you have to install a much unpredictable creator's version.

I tried installing the old WW2 Panzers mods (that gives amazing new armored ww2-era units to Russia, Amerca, Britain, Italy, Japan, Germany and France). It used to be my favorite became the gameplay was absolutely epic with those units.

Has anyone installed it and succeeded? I've tried several times and get errors and effed the whole game and couldn't even play properly without the mod so I had to uninstall and install again.

Anyways, I'd appreciate a LOT if someone could help me with this :(
Panzers Mod is fully included in EE4
Link to English version 9.02:
https://yadi.sk/d/YXteqll1XfmrH

Technical support:
https://discord.gg/qChGbAr
Post Reply

Return to “EE2 files, modding, maps, testing, etc.”