Still lagging

ImageNeed any help? Do you have a problem? Ask us! We will help you!
Post Reply
Herbert50
Posts: 1
Joined: 08 Sep 2020, 18:51

Still lagging

Post by Herbert50 »

Hello together,

since I have EE2, i had 3 different pc and the game always lagged. Even now despite my strong system.

I know it is a "common" problem and I have already red here, that the game ist just bad programmed. But i hope that somenone have found a way. I really like the game but these fps drops are awful. I have installed the patch 1.5 from here but it did not solve the problem.

My pc: GeForce 1070 Ti and Ryzen 5 2600

I would be glad about help.

User avatar
Dr.MonaLisa
High Representative
Posts: 7838
Joined: 17 Jun 2010, 11:21
Location: Poland

Re: Still lagging

Post by Dr.MonaLisa »

Hi.
As described in: https://www.ee2.eu/help/#lags

The lags are usually caused by the AI players. In Multiplayer mode, it's much better.
EE2 uses a single CPU core, so what matters for this game to run better is a high single-core boost, instead of the amount of cores.

Can you compare your performance, with the videos on my YouTube channel? https://www.youtube.com/user/LeaderEE2/videos
I use Ryzen 7 2700X. If it's the same, then there is nothing more that can be done.

Also, please make sure that DirectX 9 is enabled in UP1.5 Settings. It improves the performance by +5%.
Best regards,
Dr.MonaLisa
Ministry of Game Affairs
Department of Control and Complains
Post Reply

Return to “Help, Questions & Problems. Empire Earth II Support.”