Page 1 of 1

Can't run EE2 in fullscreen.

Posted: 03 Jun 2018, 19:39
by Hummus
Last time I played with fullscreen EE2 version was and Windows 10 previous version(don't remember the version).
The game minimize at launch and when I try to go back to the game I see black\gray screen and sometimes I see the menu for a second.
I tried to disable options in the launcher and using Maximization Helper didn't help.
The only way to launch the game is launching it in Windowed mode.
Thanks in advance for any help.

Re: Can't run EE2 in fullscreen.

Posted: 03 Jun 2018, 19:54
by Dr.MonaLisa
Hello Hummus. Welcome to the Forum!

Windows 10 1803 compatibility was fixed with update 156026 (April 2018): viewtopic.php?p=23833#p23833
- Fixed compatibility with Windows 10 Spring Creators Update (1803). Added an option to "Disable fullscreen optimizations" to Maximization Helper (checked by default, available only on Windows 10).
What version of UP1.5 do you use at the moment? I assume that it's the newest one.
In the Maximization Helper window, is option "Disable fullscreen optimizations (recommended)" checked?
Have you tried to use "Solution 1" and "Solution 2" in the Maximization Helper?
This video shows how to do this:

Please provide answers to my questions, and if it's still minimizing I'll guide you how to find the problem.

Re: Can't run EE2 in fullscreen.

Posted: 03 Jun 2018, 20:33
by Hummus
Thanks for the fast reply.
Solution 2 is working now.
For some reason I tried all options before I posted and they didn't worked.
And the last time I played the game I didn't need to use any of the fixes is it because of windows 10 latest update?

Re: Can't run EE2 in fullscreen.

Posted: 03 Jun 2018, 20:46
by Dr.MonaLisa
Yes, with every Windows Update I'm shaking from the fear thinking what will cause problems this time.
I always install Windows 10 updates before the official release to check if everything works fine on EE2. The last update (1803) seems to be very problematic (new full screen optimizations don't allow to maximize game). It took me some days to figure it out and prepare fixes (a launcher function with a checkbox in Maximization Helper).
"Solution 2" was made a few years ago, when I detected problems on some Windows Insider build. It didn't cause problems in the stable Windows 10 builds later, but now it seems to cause problems again. It is probably caused by the new "Windows Timeline" feature. But anyway, as long as a Solution in the Maximization Helper exists for it - I'm happy.