Page 1 of 1

Problem installing Patch 1.5

Posted: 28 Oct 2017, 23:03
by Resal
Hello folks,

i just stumbled across this beautiful patch and was excited to play EE2 with a few friends.

I downloaded the game via GOG (Gold Edition) and got the Patch from the website.

-> Fresh installation, no modifications.

I started the ee2_update_100-140_156.exe and began to install the patch. Nothing special.

But when the installation itself finishes, I get a strange error message. I would post it, but because it's in german I'm not quite sure if anyone could read it. But it says something like:

"We cannot find or access EE2.EXE because it's not in the named directory" - or something in that direction.

When checking my installation folder, the EE2.exe has actually been deleted. Starting the EE2X.exe the same error occures and it disappears. Strange.

I also tried it by copying those exe files into seperate folders and moving them back again. When starting the game, it somehow just starts the game without the patch. No Chance to use or configurate the game via the launcher.

I deactivated any anti-virus program, because I also thought, that windows might delete it, because it thinks, that it's a virus.

I'd love to hear from you guys,

Greetings from Germany,


Re: Problem installing Patch 1.5

Posted: 29 Oct 2017, 02:53
by Dr.MonaLisa
Hello Resal. For me it still sounds like an Antivirus problem. Are you sure you don't have any other AV running in the background? What Antivirus you are normally using? If it's Avast, then... this sh** recently detects the Launcher: ... /detection

Theoretically, Windows won't delete files itself. It must be another software doing this. If it's Antivirus issue and disabling scanners doesn't help, then unfortunately I think you should find a better AV program that allows you to have control on files.

Re: Problem installing Patch 1.5

Posted: 29 Oct 2017, 12:18
by Resal

thank you for your reply.

I checked my computer and even deactivated Windows Defender (Note: I'm using Windows 10 on the newest build 1703, so I even had to modify the registry in order to fully deactivate it.

Can you recommend any useful Anti-Virus i should use?

Thanks a lot

Edit: While checking that VirusTotal link I had an Idea. Correct me if I'm wrong, but the installation replaces the EE2.exe and EE2X.exe, right? So even if I did a copy of the original, it wouldn't work because I'm using the wrong exe? So if I would have the correct exe and put it back in that folder again it should work, shouldn't it?

Re: Problem installing Patch 1.5

Posted: 29 Oct 2017, 13:00
by Dr.MonaLisa
Hey. The newest Windows 10 build is 1709 by the way. You can upgrade it faster than Windows Update by this website: ... /windows10 (of course it's not required, just letting you know).

There shouldn't be any additional steps required to deactivate Windows Defender by Registry. When I used Windows Defender I could turn off protection by "Windows Defender Security Center".

If you want, you can try Bitdefender Total Security 2018, for free for 90 days: ... 4158281905 (and after 90 days request the trial again :P)

Yes, EE2.exe and EE2X.exe are the Launcher files which are updated every month, with Minor Updates, so it would be nice to find a solution for those problems.
I attached the current version's (156016) .exes here:
(8.5 MiB) Downloaded 45 times
Please let me know if it solves the problem.

By the way, installing Bitdefender can be a good idea, because it deactivates other antiviruses, so you don't need to worry about installer being blocked again.
So just to clear things up:
1. Install Bitdefender.
2. Try to install the patch again.
3. If it doesn't work then try replacing .exes manually.


Re: Problem installing Patch 1.5

Posted: 29 Oct 2017, 20:22
by SewerAgent

Both my brother and myself had this exact same issue. It deleted all of the game files, and when I re-installed the game, with the latest update, it did the same thing again.

Basically means I can't play the game with this patch. Everything worked fine for both of us until this update?

Very odd!

Re: Problem installing Patch 1.5

Posted: 30 Oct 2017, 01:48
by Dr.MonaLisa
The installer behavior was not changed during the update. So you guys better find which Antivirus causes those problems. For me it's unacceptable that an antivirus deletes files without giving any warning or notification about it.

I just tested the Full UP1.5 Installer and the Minor Update Installer on Virtual Machines with: Windows 10, Windows 8.1 and Windows XP. Everything worked fine, EE2.exe and EE2X.exe were not deleted.
From what we can see at the statistics page: around 50% of players already use 156016.

Re: Problem installing Patch 1.5

Posted: 30 Oct 2017, 12:39
by Dr.MonaLisa
Resal, have you solved this problem? If yes, could you post which solution worked for you?

SewerAgent, Since I can't reproduce this problem, I would need to look at this problem by TeamViewer. Teamviewer is a program for remote help:
Please tell me if you're interested in this form of assistance.

Okay, I think you both used Avast Antivirus or AVG.

Avast Antivirus detects UP1.5 Launcher files as Malware. It removes those files during the patch installation and doesn't display any warning. After that users think it's a problem with the installer. When you finally figure out that it's Avast blocking them, and you confirm that the file is clean by checking it on - it's almost impossible to find the "file exceptions" menu. Please avoid Avast whenever possible, and find a better alternative (which is not AVG because it's owned by the same company and uses the same "virus" definitions). Avast is NOT good at detection. It simply blocks new/unknown/rarely used files, but it allows real threats. Users with Avast Antivirus installed should not report any UP1.5 issues as Antivirus compatibility is not my problem.